We are currently investigating extended delivery time of inbound emails on Smart Inbox.
Incident Report for e-conomic
Resolved
This incident has been resolved.
Posted May 25, 2020 - 11:43 CEST
Investigating
We are currently investigating extended delivery time of inbound emails on Smart Inbox.

We will provide more information as soon as possible.
Posted May 18, 2020 - 10:02 CEST
This incident affected: web application.