Issues retrieving statements from BankConnect integrations
Incident Report for e-conomic
Resolved
This incident has been resolved.
Posted Dec 10, 2019 - 12:14 CET
Identified
Some users are currently having issues retrieving statements from BankConnect integrations - we are working on a fix
Posted Dec 09, 2019 - 21:07 CET