We are currently investigating delays in email delivery on the e-conomic application.
Incident Report for e-conomic
Resolved
This incident has been resolved.
Posted Jul 30, 2020 - 14:43 CEST
Monitoring
A third party was affecting our job execution performance. A fix has been implemented and we are monitoring that the results have the desired effects. All delayed emails should now be delivered.
Posted Jul 27, 2020 - 15:19 CEST
Investigating
We are currently investigating delays in email delivery on the e-conomic application.

We will provide more information as soon as possible.
Posted Jul 27, 2020 - 13:19 CEST
This incident affected: web application.