Visma Connect signin experiencing service disruption
Incident Report for e-conomic
Resolved
This incident has been resolved.
Posted Sep 13, 2019 - 08:08 CEST
Investigating
Visma Connect signin is responding slowly, or not at all.
The issue is currently being investigated.
Posted Sep 13, 2019 - 07:23 CEST