Login page is currently unavailable
Incident Report for e-conomic
Resolved
The issue is considered resolved.
Posted Jan 14, 2020 - 16:50 CET
Monitoring
We have identified and fixed the issue, we are currently monitoring.
Posted Jan 14, 2020 - 15:09 CET
Investigating
Our login page is currently unavailable, we are investigating the issue.
Posted Jan 14, 2020 - 14:37 CET