We are currently investigating longer response times on the e-conomic application.
Incident Report for e-conomic
Resolved
The recent deployment took longer than expected and we were thereby running on lower capacity than normal.

The deployment was implemented successfully and response times are back to normal.
Posted Dec 04, 2017 - 12:58 CET
Identified
We are currently investigating longer response times on the e-conomic application.

We will provide more information as soon as possible.
Posted Dec 04, 2017 - 12:43 CET