Slowdowns
Incident Report for e-conomic
Resolved
An failing internal dependency has been identified. We are monitoring it - and will post a new update if relevant.
Posted 6 months ago. Mar 21, 2019 - 16:33 CET
Investigating
We are still seeing slowdowns on the application - we are investigating
Posted 6 months ago. Mar 21, 2019 - 15:28 CET
This incident affected: web application.